Buy FOCBOX Unity

VESC FAQ | Connect two VESC via CANBUS for dual motors

can-bus
dual
vesc

#61

I have noticed with my dual VESC’s (via canbus) that if I’m on cruise control and I load up one wheel the motor spins up harder to try and overcome the load, but if I load the other wheel it just stops.
I have tried turning on and off traction control option and it doesn’t seem to make a difference.
its the motor attached to the slave VESC that stops under load.

is there some sort of setting that I’m missing?


#62

found the issue, it looks like it was a faulty canbus cable.


#63

Traction control if found doesn’t work as well for hub motors any way!


#64

I thought so too, but it think the setting needs to be changed from 3000 erpm differences to lower number I suppose.


#65

Yeah i hadn’t put traction control on, I did have a faulty canbus cable though.


#66

good job you fixed it


#67

Does anyone know if its okay to have slightly different parameters in motor integrator limit as well as BEMF coupling on dual motor configuration.

After running detection, I have 2 results

Left motor:
Integrator Limit 95
BEMF Coupling 650

Right motor:
Integrator Limit 90
BEMF Coupling 600

Should be left and right motor configuration the same? or should it be different according to the uniqueness of each motor?
What re the implications if they are different? or if I average them and have them on the same value?


#68

Just give this a little push, cause I would like to hear the answer to Laurnts question.
And say hello to this community:)


#69


… if it could help …


#70

No, this is perfect, no motor is like the other and the values are near enough.


#71

Hi All,

I seem to be running into an issue with the dual motor setup I’ve changed using the BLDC Tool.

I’m using an Enertion Dual Raptor, so I’ve got two VESCs (4.12) controlling it. My goal is to change it to FOC mode. For that reason, I got the BLDC tool (V2.15), and changed the firmware on the VESCs from 2.16 (default) to 2.15 (compatible with 2.15, couldn’t find firmware 2.17 or 2.18). I managed to change 1 to FOC mode, but the other one seems to be unresponsive. When I try measuring the motor configuration settings for FOC, it doesn’t do anything at all. Some of the strange things I notice are the resistance is about 300x as much on the motor that doesn’t do anything than the one that functions (.02 vs 6.3). The strange part is I can connect using CAN forwarding (set master to one, slave to 2, can connect from either to the other.

As for settings for the app, I set the master one to send status over CAN (if slave sends status over can, the one motor that does work gets conflicting signals). In PPM mode (since I’m using a steez remote), I set the multipl escs over can on both, then I tried disabling control on the slave, then enabling multiple over can. Nothing seems to work. Any one have a suggestion what I should try next?


#72

Does the other still work with bldc mode?

Sometimes there occur some problems on firmware flashing.


#73

Just uploaded the VESC enertion 6355 firmware on the “bad” VESC… Every time I try reading the configuration from the motor, I get a bad detection code:


#74

And the other one can be read without problems:


#75

To add more detail, I know there’s the VESC faq posted here that talks about what to do, but in making the board, there this black epoxy sort of stuff that prevents me from checking the wire connections to the motor.

That being said, here is the current/duty graph which makes me convince it’s a bad motor/bad motor connection:


#76

Switch the motors, if the problem follows the suspect motor, it’s the motor.
Otherwise it’s the vesc.

Go back to bldc mode.
Manually Copy the settings from the good vesc to the suspect vesc and see if it still runs in bldc.


#77

I would, but there’s this black epoxy that’s on the board that prevents me from doing anything:

@EnertionSupport, Do you have suggestions on how I can unglue this or maybe have it sent in to be checked on if you have to have special tools for this?


#78

it is just hot glue


#79

I’m having trouble finding these connectors in any store or online without buying 20+

I found these at hobby people (see below)

I bought (2) Female JST connectors and plan to solder them together to create the female to female connection.

Will this work?


#80

You can get one of these and cut/ignore the last cable

BTW, your picture is broken.