Certified FOCBOX Suppliers | Get Focbox Unity

Raptor- Replaced VESC and remote...problems

raptor
remote
vesc

#1

So we replaced the VESC on Raptor single drive and a remote. I did motor detection and got the settings from the old VESC (I think). I also recalibrated the new remote. Anyway, it’s a death trap now. It will cut out randomly and decide to just stop. This happens within the first two minutes and then has issues with any remote commands (accelerate, stop, slow start, etc.). When first turned on it seems fine but then BAM!

Here are the VESC settings






#2

Try ppm only on your app page, your max and min settings seam to be off. It should be something close 1 min and 2 max.

Untick the can fowarding and traction control (single motor)

Set your max erpm to 70000


#3

Ok. Updated to new settings, except remote. It is a new ‘Winning’ remote. It won’t zero out without setting it to 1.35. Otherwise it will take off.

Anyway, no difference. Same results…


#4

Did you charge the remote, also witch binding procedure did you follow


#5

Also, your remote setting are a bit off, did you set the pulsewith parameter usine the display


#6

This might help you


#7

So I wanted a chance to update and test before I replied. It didn’t help. Still ‘stutters’ at random times. I’ve had it on the bench with no load and I have seen it happen. Since the VESC and remote have been swapped, could it be the motor? Battery??? I’m stumped.


#8

I would say the two likely issues are.

  1. Motor shorting inside. Open it and check for small burn marks. To open the motor you will need to remove it from the mount. Remove the motor pulley. Then remove the circlip at the Base of themails exposed shaft.

  2. The fail safe needs to be reset on the remote.
    Binding procedure as follow:

1).Check and make sure all the wires are mounted,and the remote is off, insert the bind plug into CH3(Bind) on the receiver;
2).Switch on the boards power, you can see the receiver red light flash;
3).Press and hold on the bind button on the remote and then switch the remote on;
4).You should notice the transimitter go from flashing red to solid red,and also the solid red of the receiver;
5).Once you see a solid red light, you now know the two are binded together,and please pull the bind plug out (do not turn off the power or touch the throttle) this is important, so the remote can record the throttle nutural position to set as the fail safe.
6).Then you can test it again by turning off the controller and it should flash. if you turn the power on Transmitter back on it should go back to solid red.

  1. Set the ppm / deadband setting in vesc.

#9

You need to update your firmware, it has the max ramp step error: PSA: Remember to reset your max current ramp step when programming your VESC