Certified FOCBOX Suppliers | Get Focbox Unity

VESC throttle not working


#1

So I’m having an issue setting up my VESC, where starting up the throttle (just ever so slightly) will make the motors go full speed and pulling the throttle, even more, will just result in no speed change. I have added a video with the issues. Does anyone know why this is happening? I believe I already did the throttle range calibration, at least the display reads the throttle correctly, but it’s not functioning properly.


#2

With no load, you won’t be able to see any speed change… The rpm will go at their max in a instant… Also to protect your vesc put the max erpm at 70000 max


#3

No issue there, in current control, you will ramp the current from 0A to your motor max.

But with no load, you motor will hit it’s max rpm at 5-6A (could even be lower)

Put a load on in it, whole different story.


#4

But the motor steps in to hard. please make a Screenshot of your PPM settings. I think we can find the issue there. Just set it in the PPM window to disabled and then switch on the Display checkbox. Then you should see that the value changes with the throttle. Once that is working and adjusted correctly you can switch it back on and have fun.


#5

With no load it would propably take 5-10% throttle to hit the max rpm.

But yes, calibrate your ppm setting like @Ackmaniac suggested


#6

Yeah, I calibrated my PPM settings… Is that the same as the throttle range calibration? Anyway, I put a load on it (both standing on it and putting it on the ground without standing on it)
I took a couple videos which I linked below.
When it was just on the ground, it moved, but it still went full throttle after a bit of "jiggling"
When I stood on it, it would not move, instead, the motors just moved back and forth very quickly (ie - jiggling) it was kind of moving/rolling backwards though?
I’m not sure.
Any ideas?


#7

can you post a screen shoot of your parameter ? I think you might need a little push to make this board move (you should test it outside, a try to take on more speed)


#8

Give your hubs a chance, just a push start is all you need.

You can also slightly increase your startup boost in the advanced tab


#9

I believe the start-up boost is 0.09
^^ but that’s only on one VESC


#10

Is the traction control enable ?


#11

VESC is not over CAN. Y servo connector


#12

Can you post screenshot of your parameter ?


#13

hubs definitely won’t start from a stop, especially on what looks like carpet.

on my dual hummie board I literally cannot move if the board doesn’t have a push… and that’s 10s 40amps a piece to the two hubz.


#14

hmm, yeah I tested it on the street just now… much better


#15


#16

Is your firmware 2.16 ?


#17

My VESC is 4.12


#18

Firmware… Not hardware… Or What is your BLDC tool Version?


#19

Not sure… BLDC tool was just downloaded like 2 days ago from Jacobs site.


#20

OK… It weird because the MAX CURRENT RAMP STEP is suppose to be at 0.0400 in the 2.18 default parameter. But in the 2.16 Firmware it is at 50…

Can you go in the Firmware part of the BLDC tool and make a read.