Certified FOCBOX Suppliers | Get Focbox Unity

VESC-Project.com is online! Public VESC-Tool download


#467

After you uploaded BLDC tool firmware from vesc-tool, did you try uploading vesc-tool firmware again?


#468

I’m getting confused here bro, You mean uploading the Vedder Firmware 4.12 (from Github) twice using VESC tool?


#469

You said uploading file from GitHub didn’t work. So it might be possible to upload old BLDC firmware just so you can get the option to switch back to vesc-tool 412 firmware.


#470

What I tried is to upload the old BLDC firmware which I downloaded from Github, after uploading it I couldn’t select a different hardware just 48.

Ussualy when the firmware is uploaded the VESC reboots itself and you are able to connect in this case when I upload the formware I get disconnected and it’s not possible to connect unless I cycle the power from the battery, I wonder if this could cause a failure in the firmware upload.

After I cycle the power I can confirm the FW wasn’t uploaded succesfuly.

I uploaded original 2.18 FW for HW 4.10_4.11_412
I uploaded ackmaniac 2.54
I uploaded ackmaniac 2.53
I uploaded ackmaniac 2.52

Non e of them worked


#471

Did you try with st Link programmer?


#472

That’s what I’m doing right now, I’m trying to find the instructions on them. Furtunately I have an ST Programmer here with me


#473

Focbox fried?


#474

Hey @Titoxd10001 thanks for your help! Thanks also to @Surfer

I was able to recover my VESC via the ST Link programmer, I’m so happy o bought it from eBay months ago, I might need it sometime, I said a while back.

We’ll the issue was, once you program the incorrect hardware version you won’t be able to go back to an older firmware, when flashing the firmware you will also flash the bootloader, an incorrect bootloader won’t let you flash an old firmware, do you get stuck with a bricked VESC.

The solution is to program an 4.12 FW with a ST-Link and after successfully installing the FW, flash the the Hex file which contains the bootloader, at the beginning o tried to flash the bin file FW only but couldn’t update the firmware so after flashing the Hex file everything went back to normal.

Finding the procedure to connect the st link was not easy, I had to watch a video from Jared and then find out the pinout to connect the ST-Link to the VESC, you just need to connect 4 cables 3.3v, GND, SWDIO and SWCLK, all commercial VESCs have these pins labeled at the back of the board, so don’t look for a pinout online, you will loose time as me, just plug them with the supplied wires.


#475

Strange you had to go through all those steps I was able to change firmwares from vesc-tool. Thought the wrong firmware was the reason your board caught fire


#476

Those firmware issues were on my Vanguard build, it’s running good now.


#477

The website seems to be offline to me. Are you guys able to go on it?


#478

Every time i try that site its always offline


#479

Damn that sucks. Does anyone have a copy of the latest FW for HW4.12?


#480

Benjamin installs a new powerful server. The site will be online soon.

Frank


#481

when will the reference hardware design be relleased?


#482

To Frank and Benjamin.

vesc-project.com is down another time.

It seems that the new server didn’t solve the problem.

Hope you will find a lasting solution.

Have a Nice Day.

Thierry


#483

It’s still on the old one. Online soon…

Frank


#484

When it is back online tonight it’s on the new server and fast fibre connection.

Frank


#485

I just want to confirm the procces of uploading a bootloader to a VESC without a bootloader.

Which version should I choose? 40 & 47 and so on… or the 60?
Then, I should just hit the download button?

I tried to search for an answer but couldn’t find one, I don’t want to mess the VESC…

Thanks!


Ollin Vesc Questions
#486

Trampa is only maker of ver. 60 @ the moment