Certified FOCBOX Suppliers | Get Focbox Unity

VESC-Project.com is online! Public VESC-Tool download


#447

Man if we meet I owe you a drink.


#448

@Vanarian an, Do you want to uncompile the 3.26 bin file to obtain source files ?


#449

I just made tons of screenshots for those who struggle with the setup.
Step by Step through the Wizards…

http://www.vesc-project.com/node/20

Frank


#450

Nice with some dokumentation… thumbs up :+1:

Any news about the R = 0 bug… so i can follow your FOC tutorial :wink: ?


#451

I just updated my vesc from 4.12 to 3.29 and everything went with zero problemos.

I just have this one issue of setting up my controler. I use a PPM(Benchwheel) controler with thumb throtle and i already set it up with wizard but for some reason the throtle distance that is available is very small. I know it prob has to do something with throtle curves that i know nothing about.
Does anyone have any idea how to set the curves correctly, so that i can actually use the hole wheel of the throtle (i mean half of the wheel, backwards is ofcourse brake, which i think also needs adjusting).
EXPANDING THE THROTLE. :point_left:


#452

If you used the app wizard I camt imagine why it wouldn’t have all the range.


#453

Because 3.29 changed back to current control to fix the braking. A later version will likely have watt control back with fixed brakes.


#454

@rok @Jinra Has nothing to do with that. The VESC-Tool has never used “watt control” in the fist place.
You should have the entire throttle way anyway. The power distribution along the throttle way has something to do with your settings. Try setting Motor max Amp = Battery max Amps (if you battery is strong enough) for a linear power distribution along the entire throttle way. You will only get realistic results when you run the board under load. You can’t see the result on the bench, since it is a current controlled system.

Frank


#455

@Pimousse Yes ! Even if not grouped correctly I could just arrange the sources. But I kinda filed to extract them for now so that’s a stalemate.

@BigBoyToys Actually it is a different fork older than VESC 6 (creator started working on it since 4.8hw versions). Could still benefit from making a VESC 6 variant based on mines and it would work very good though. That’s next step once I’ve ironed mines out and stressed them as much as I need (6xx can only do better IMO with same mods).

My units are LM5109 based (replace the DRVs, good up to 100V) and also have 6-FETs all on one face kinda like VESC 6 and FOCBOX so as easy to cool down. But I don’t have Direct-FETs.

I also GPIOs assigned differently (probably due to modular layout, LM drivers + boot and reset buttont to switch between normal USB and DFU-USB connections).

@trampa That’s not what @Ackmaniac said and he gains no money from saying it did till 3.28 version.


#456

Just did what you said and i noticed no difference. Time to take it for a spin outside, so that i have a better answer for you.
Thanks though, very nice and user friendly tool! :relaxed:

TESTED
The throtle feels very different under load, i like it. I also like FOC. And turtles :turtle: :wink:

I do have one question tho regarding brakes. This may not be the vesc or software problem but rather my settings. When i pull the throtle way back it does break, but does so very slowly, and never totaly stops the motor from spinning. It doesn’t blocks it completly is what i mean. How to fix it?
I am running 10s4p with 200kv motor. I have a motor max set to 60A, brake max to -60A and regen to -16A.


#457

i don’t know if someone asked it before…

1- it’s safe to use this new software with a vesc 4.12 ?

2- if you want to use it in a vesc 4.12 you have to upload another firmware?

thanks


#458

yes on both


#459

Hi @rok, -16A is not a lot of current for the brakes, so don’t expect to much. -60 for the motor regen doesn’t help to much if your battery can only swallow 16A. This weakness is dominant at speed and will get better when you slow down. At top speed your brakes will be limited to -16A, since the motor generates nearly at full system voltage.
The lower the voltage drops on the generator side, the more Amps the motor is allowed generate.
On the battery side the VESC will scale up the voltage again, lowering the currents back to your 16A battery min value.
This means: If your motor generates 32A at 20V (=640W), your battery could be charged with e.g. 40V, 16A (=640W).

In consequence the battery min pretty much defines your brake power at high speed, while the motor min value becomes more dominant at low speed. The further you spread the values apart, the more you will experience a non linear behaviour of the brakes.

I will try to make a Duty Cycle manual together with Benjamin to explain the matter in detail.
So do some test runs in an area where you face no obstacles to find your settings.
Battery min is the bottle neck for strong brakes at speed! This is why you want a strong battery pack allowing fast storage of energy. This is why you want a high P count.

The motor brakes will not stop your board totally! It gets better with sensors, but if your board doesn’t move, your motor won’t spin and can’t generate electricity. If it doesn’t generate electricity it doesn’t create resistance.
VESC-Tool has a feature called “hand brake”, actively braking your motor through the use of a current flow through the motor coils, blocking the motor from spinning up. This consumes energy from the battery!
You can’t easily activate it from the remote at this stage.

Frank


#460

Did i miss the point why Ben can´t just programm the Vesc 6 braking behavior like the 4.12?
So you get the same experience with same settings like before?!
Brakes where beautiful and worked like a charm on 4.12.

My settings look like that on a dual 6355 drive with a 10s4p:
Motor -60A
Bat -12A
Brakes are nice and strong at all speeds and block the motor completly when standstill.

So shouldn´t be a problem to get the same results on VESC 6!


#461

Hello guys, I uploaded an incorrect FW version, then in order to correct it I ticked on Show non-default firmwares and now I can’t even connect.

I’m having an error Invalid seial port: \.\COM6

Did I brick my VESC?

Update: I cycled power and now I can connect again, but I can’t change the HW version, as soon as I click on connect the Hardware Version List deletes 4.12 and only shows the HW 48


#462

How did you fix this issue, I’m having the same issue as you, I incorrectly uploaded the HW Version 48 instead on 4.12. I can’t upload the 4.12 hardware version anymore, is there a trick?


#463

Download FW for HW 4.12 from vedder github. Use the custom file tab in VESC Tool to upload the firmware

Actually switched back to extended BLDC tool using this method


#464

I downloaded VESC_default for hw_410_411_412 from Vedder Github, flashed the firmware and I’m still stuck on hardware 48. Any other ideas?

There are other firmware inside the hw_410_411_412 folder

VESC_0005ohm.bin
VESC_servoout.bin
VESC_ws2811.bin

Should I try those as well?


#465

If you upload BLDC firmware and back to vesc-tool firmware it might give you option for 412


#466

I tried to use BLDC tool (old software) but I can’t even connect, I’m getting this error:

The firmware on the connected VESC is too old. Please update it using a programmer

I’m getting worried, I could use some help