Pre-Order Focbox Unity $249 | FocBox $99USD

VESC-Project.com is online! Public VESC-Tool download


#386

I found it. But need to translate from french now. :wink:


#387

Can anyone help me out with the remote settings? For some reason my remote stopped binding and I switched to my old clunky one and I can’t get it to control the board.


#388

At last I was able to set up my motors in FOC with my FocBox (early version), but when I set App Settings and select Current no reverse with brake and give throttle to the remote my motors won’t spin even though I can see the PPM mapping in real time.

Is there a trick when setting up FOC?


#389

nope. thats the dead end just like rest of us. no ppm for foc at the moment


#390

Shit! Glad to know about it at least, no need to loose 2 more hours


#391

what are you talking about I’ve been running ppm on foc 3.29…


#392

is it a focbox? then tell me the solution. why does the motor perma brake when connected to receiver after successful detection. i didnt tried the minor updates(brake fix) but does this makes it work?


#393

well in his screenshot his mapping is wrong. I noticed this happening with one of my controllers and not a different controller. Probably has more to do with that rather than being a focbox. In that case you just have to record and enter the ppm values manually.

@Eboosted


#394

PPM wasn’t set at that particular moment, however, trust me, I did set it later and got the same issue, master motor permanently braked, it also releases when selecting BLDC back again.

Yes, I have a FocBox and it does perma brake as soon as I select FOC, no PPM signal transmited to the VESC, no spinning from the wheels.

The procedure to be able to run FOC detection without getting the “R is 0. Measure it first” I used was this:

  1. Run Motor Detection Wizard
  2. Load default values
  3. Select BLDC
  4. Use these current settings:
    Motor Max 70A
    Motor min -60A
    Battery Max 40A
    Battery Min -25A
  5. Set up cutoff start and end, in my case 12S4P
    Cutoff start; 36V
    Cutoff end: 33.6V
  6. Select hall sensors
  7. Increase D=0.05 to D=0.1
  8. Run BLDC motor detection
  9. Hit apply
  10. Save motor settings
  11. Go to General tab and select FOC
  12. Go to FOC tab
  13. Hit RL
  14. Hit lambda
  15. Hit apply
  16. Write motor settings
  17. Set App Settings for master VESC

After doing all these and try to use the remote, the master motor permanently brakes, feedback from the remote


#395

does FOC cause it to fully brake when you have both the below settings turned off?

App Settings > General > App to Use = No app
App Settings > PPM > Control Type = Off


#396

That’s a good question, I didn’t test that, however even when I fully pull the throttle while I watching the PPM going all the way to 100%

App Settings > General > App to Use = Current no reverse with brake
App Settings > PPM > Control Type = Current no reverse with brake

Motors won’t spin, master motor perma braked

As soon as I switch to BLDC motors spin perfectly, no perma brake

Hope this is only a glitch and newer versions are released


#397

Huh that’s pretty weird… Is this with one VESC no split Y or CAN connection? I’d take those off if you have them to eliminate other factors.


#398

I have the same problem with my focbox. FOC does not Work… The motor is locked , the moment i connect my receiver to the VESC. I got the R = 0 bug, if the receiver is connected under foc motor detection. So i disconnect the receiver , run the foc motor test with succes, connect the receiver again. And then the motors wont spin. I can all so se the ppm output in gui, and the end and mid points is spot on. So at the moment i run BLDC :-/


#399

The issue is not related to ppm. FOC simply doesn’t work correct.


#400

How to explain that people run FOC with PPM flawlessly (like me on 3.28) and others don’t ?
It’s pretty hard to find a common factors through all these feedbacks.


#401

Has nothing to do with PPM if you ask me. Seems that high resistance motors work better than low resistance motor.
Does anybody have the Version 3.26 for 4.12 hardware? Just want to give it a try.


#402

Before i could get bldc motor test to work on my focbox, i had to play with the test values (sk3 6364 190kv) could it be the same ‘problem’ with foc motor detection ??


#403

To figure out if you’re right, it should be interesting if someone with the PPM not working can try to run the motor in FOC through VESC Tool with manual controls.
Because I really don’t get why it’s so random.


#404

Benjamin tried a FOCBOX that was reported to have the R=0 issue and would not spin up using PPM.

We plugged it into one of our motors and had a straight success using the wizards. No issues!
Motor: 118 KV Trampa

Next step: Higher KV motor test, hoping that the issue can be replicated soon. Benjamin has a couple of motors to try…

If you have a low KV motor to the hand you could simply give it a try.

Frank


#405

190kv gives me R=0 fail…