Certified FOCBOX Suppliers | Get Focbox Unity

VESC-Project.com is online! Public VESC-Tool download


#346

addressed =/= fixed :slight_smile:


#347

I’m I missing something? Please give us some more info @jinra


#348

in 3.29 brakes seem to be back to normal (like in 2.18/2.54). I’m using -25A right now, but I’ll try dropping it down to -10 again to see how my brakes are. It was a bit weird that this wasn’t mentioned in the changelog though, unless it falls within “disabled throttle limit scaling”


#349

The best way to figure out that has been changed is yo lokk closely to the code changed.
Github is a powerful tool that allow to quickly focus on what has been added/deleted/changed. :wink:

If really needed, it won’t be too difficult to compile a custom firmware using Watt mode for accel and current control for brake.
@Ackmaniac wrote the code in his pull request.


#350

I just uploaded 3.29 FW, I’m testing in 30 minutes. I’l report back as soon as I get home.

Here are my new settings:

Motor max: 70A
Motor min: - 60A
Battery max: 40A
Battery min: - 25A

Brakes are much better now, almost as much as the 2.54 FW, but still at high speed if you pull the brakes hard you feel less braking power than the old firmware.

There was a huge difference in power delivery going on motor max from 60A to 70A, the 6374s are shining at its best now.

I still feel uneasy pulling such big amount of current onto the battery, I need to make a log as soon as the Bluetooth app starts working


#351

I think, you’ll like it. The brakes are def better, hopefully we get watt control throttle back with different logic for braking.


#352

I didn’t feel any non-linear braking, maybe Ben changed the braking logic current calculation


#353

yea he did, it’s current control like in 2.18 again


#354

Did you ever try FOC with the new firmware? I’ve been running it for a few days and haven’t had any issues with my TB vesc. Super smooth!


#355

I wonder why didn’t Ben corrected the error on setting up FOC. I’ve heard Ben got a VESC X hope he finds the fix for the dreaded “R is 0 please calculate it first”


#356

When I ran into that error, I ran BLDC detection (but didn’t apply or write), then ran FOC again and it started work. I was using an ollin VESC, however.


#357

Are you currently runing FOC?


#358

yes sir :smile:


#359

I ran the 3.26 for around 900km ; I’ve updated to 3.29 yesterday evening. Will ride the full weekend as its sunny in Paris and report back.

Just after the update, I went to setup my VESC and going via the Motor Wizard. Everything went fine except on the Hall sensor detection that failed in FOC. So I had to do it outside of the wizard and for some reasons and without changing anything it worked fine on the wizard now. I think I’ve filmed a video of this.

I’m running 12S4P VTC5A on dual 150kv - no BMS with a 80A fuse (need to get a 100A)
Motor max: 40A
Motor min: - 40A
Battery max: 40A
Battery min: -12A

Cheers.


#360

Why would you need an 100A fuse with 40A battery max? Even dual you’ll never pull 80A continuous and even if you do your fuse still won’t blow, at least for a long long time.


#361

cause this will enable to move the batt/motor max to 50A as I’m running dual VESC and align to 100A


#362

ah i see. I’d bet you would never blow the fuse even if you use 100a now. I used 80A (40A x2 vesc) battery max with a 40A fuse just fine up the steepest hills in SF.


#363

hehe lucky guy. I blown a 40A fuse with 60/60A on my tests so now I really always align the fuse to the batt max on the VESC although as you said I may be extra careful.


#364

yea perhaps those big ol AT wheels just pull more current than my comparatively small thane wheels


#365

Why do you run only 40A motor max? Why not increase it to 60A it even more? I increased the motor max from 60A to 70A on a 12S4P and the torque was insane!

On the new firmware it seems battery min needs to be increased almost double the regular old firmware current in order to keep the same braking power