Get Focbox Unity on Amazon NOW!

VESC Monitor Android App

A very nice tool was @DeathCookies Data Analyser ttps://www.electric-skateboard.builders/t/vesc-data-log-analyzer-vdla/16582

Sadly he decided to remove it because of missing donations. Maybe the community can help him out.

Maybe for future i can add a map view of the old data as well. but for sure not as advanced as Deathcookies version.

4 Likes

confirming it works, just remember to turn on ppm+uart, i think you need to use FOCBOX_TOOL to enable that.

Are using the unity’s BT module or HM10 peripheral?

this one, didn’t even try with the onboard BT

1 Like

Anyone having issues connecting with the app

Edit: App didn’t show board name in red, but was still able to connect

I experienced the same issue, need to have a look how that can be possible.

1 Like

Oh sweet! So now I can run my ack app with the unity?!

I assume it just gives telemetry and you can’t change settings?

Hi everyone, i have issue with the app, i downgrade my 2 board from vesctool 3,53 (too much connection lost) to ackmaniak 2,54 but the app don’t work.

I use the flipsky bt module who worked with vesctool app

-ppm and uart is ok -baud 9600 too (tried with 115200, nothing better) -autorisations ok

Bt board is recognized but there is no data information, and “esc not connected” message.

I’ve tryed to uninstall app and fw 3 times, no more chance.

i have a shitty huawei psmart who have many trouble with bt signals but he worked with my bt flipsky and vesctool fw.

any ideas ?

Guess that the onboard blueetooth module isn’t a low energy module and my app only works with these.

1 Like

Thx for your answer, so a cheap wish like bt module should work ?

I might have made a very basic site, that has a basic VESC log analyzer. You can choose to not save the data online, but if you do, the data is stored for a week (so you can share the link to other people).

Poke @Flasher

2 Likes

Works well for most. But I do have some that show rolling at a max of 1-2 km/h :joy: Otherwise, this is perfect

Flipsky’s BT module won’t work with Ack’s app, tried it before :frowning:

1 Like

@Ackmaniac e​sk​8.n​ews

Yeah, what solition did you find ? I tried many time wiring with my aliex hm10 and no more result, app is mute, bt is well scan but no data apear

I didn’t try to make it work, I know that some hm10 modules work but I didn’t borther to try…

I recently got the app on a new Android phone, and in my phone’s Bluetooth settings I can see the Bluetooth chip that is connected to the VESC (DSD TECH), But in the VESC monitor app, it is not visible. I tried redownloading the app as well. Suggestions?

Ackmamiac, I am having trouble connecting my phone to the Bluetooth module. My phone sees it in my settings but not on your app. Suggestions?

To all using flipsky bluetooth modules. They do not support ack. You need to buy an actual hm10 bluetooth module. Easily bought on amazon and even easier to wire up :slight_smile:

Glad you like it! For the 1-2km/h speed, I might have an idea of why it’s happening. You can eventually send me the file so I can look at it, if you want to.

1 Like