Certified FOCBOX Suppliers | Get Focbox Unity

VESC + Kama nunchuck can't use break [Resolved]


#1

Hi Builders.

I can’t use the break anymore.

  • The cruise control still work good (both acceleration and deceleration)
  • The acceleration (no cruise control) work good.

Please help me find the way to fix this.


VESC FAQ | Connect The Nyko Kama wireless wii NunChuck
#2

Did you click on the “display” checkbox in the nunchuck tab and check if the brake throttle movement is recognized by the VESC?


#3

Yes, its recognized but still not break. The break only work when the wheel is not rolling (not have momentum). I know that when I try use my hand to rolling the wheel.


#4

does the VESC brake when you control it via the keyboard?


#5

I haven’t try and I not sure how to break by using keyboard. Press forward then backward?


#6

Yep, when the VESC is hooked up to your computer you can control the motor with the <- and -> arrow keys


#7

that graph looks like its way too far back if that’s at neutral.


#8

This is unrelated to you question but I noticed that you seem to have the Max current step bug in your firmware.
Look at the setting on the motor config/advanced page.
Its reading .4 and should be .04
The bug multiplies the value by 10 every time you write to the vesc.
It will eventually damage the Drv chip.
The current download of bldc tool with firmware has the bug fixed.
if your not able to update the firmware then you’ll need to set the value to .004 before writing to the vesc.


#9

Just FYI your battery cut off end should always be lower than start. Right now, it’s higher.


#10

I’ve resolved by re-upload firmware 2.18 for PBC 4.10. Thank you guys.