Certified FOCBOX Suppliers | Get Focbox Unity

VESC iOS Bluetooth App

vesc
hm-10
bluetooth

#429

Can someone post a screenshot for Dual VESC split data if available, I would like to see a side by side of Master and Slave VESC temp and amp.

Is this even possible?


#430

Cool App. I didn’t know my VESC got so hot!


#431

Is it possible to run more than one board/Bluetooth module on this app? @twan


#432

You can connect to different boards yesss


#433

New update is out.

  • Apple watch os 3.0 support
  • raptor 2.80 fw support
  • fix min/max values on temp F
  • FAQ page sizing
  • add raptor 2 outline

#434

Thank you for adding Raptor 2 support! The app is the perfect companion for the board. Really nice work


#435

Twan, First I would like to say THANK YOU for developing this awesome app! It’s a must have have for most of us. Game changer for sure.

I could use some help. I have a Laxroix with the focbox vesc. I had no problems connecting it to your app a couple months back and it worked flawlessly for the past two months. Then about two weeks ago it started to only partially connect, only showing my “esc temperate” and never fully connecting to my Bluetooth, under status it just keeps flashing “connecting to Bluetooth”. So the battery/voltage and speeds are not registering. In My phone settings under the Bluetooth it shows “connected”. What’s strange is that it started working again for about a day or two but now I’m back to not getting it to connect.

I’ve tried uninstalling the app and reinstalling a few times. I’ve tried turning on and off my Bluetooth. I’ve tried going into your apps settings under Bluetooth and selecting MLT-BT05.

Any suggestions sir? I’ll attach a few screen shots and video. Thanks a whole bunch for your time!!


#436

Funny bc I’ve had the same issue on my diy…a few months back when the app was in flight test mode it worked flawlessly & I loved it… but now when I connect it I only get Partial information reading from the app… some times I get temp only or battery only and maybe even mph only… at first I thought it was my BT module (metr Pro) but after switching it out to another BT module and making sure my vesc (focbox) app configuration was Accurate over & over again I’m still getting the same results… :frowning:


#437

Thank you for your support! It is much appreciated.

Darn, hearing these problems and can’t figure out the problems make me angry I want to make the app work smoothly for everyone but seems like there’s something going on that I will have to take deep look into. I will spend this weekend and do this.

Make sure your Bluetooth wire is fully connected too, over time vibrations might break the solder joint on the modules. -> also double check can fwd is not on.

What FW versions are you guys running @ualsteve94 @Rod12579


#438

Hello Twan, thanks for getting back to me! I just emailed Alex from Lacroix to find out what FW version we are running. I know it’s an older version since it wouldn’t allow me to connect to the Vesc project tool, I was only able to connect to the BLDC tool.

I’ll let you know the exact FW as soon as I hear back from Lacroix. Thanks :pray:t4:


#439

Mornin Twan. So my firmware along with all the Lacroix boards is version 2.18

Thanks . Have a good weekend.


#440

I’m still waiting for the version where you can have multiple (board) account.:slight_smile:


#441

Hi Twan,
I also have a Lacroix and the FW is version 2.18.
Let me post some pictures to give context / data:

  1. As you can see , the timing on Xmatic app is too much. It should show 53 minutes but I don’t know why the timing on Xmatic is always too much (in this case 1h10minutes). (FYI, speed and distance Source is from Motor).
  2. How do you calculate the average speed? If I do the math, then 1h10 ride for 15km doesn’t give me 19km/h in average.
  3. The temperature shows -273.2degrees. How is that possible?
  4. How do you calculate the elevation and the wind?

Thanks a lot!! This is a great app,
Cheers
Olivier


#442

I think I can answer some of these questions after a few weeks of using the app.

  1. You need to set your gear ratio in Settings >> Gearing so it can calculate the speed accurately.
  2. That temperature is when you launch the app without an internet connection, it’s just weather data using your current location.
  3. Same thing as above.

Btw, why is the FW version so low? I thought most people run at 3.xx


#443

@twan hey I notice there’s a bug when you set the color of the map line and the map pin color. I set mine to green for line, red for pin, and when I restart the app it resets to green for both of them. Can you fix this? :grin:


#444
  1. I did have the proper settings, approved by Lacroix. Here is a copy screen:

So the settings are correct. @twan what should I do?

Fw 2.18 is the one installed by Lacroix…


#445

Hi @twan
It seems that when I go below 10% of remaining battery, the distance covered goes to zero. See picture.


#446

So i finally got my DSD HM-10 to connect to the app. But i cannot get it to connect directly to the VESC tool via Bluetooth. Any ideas?

I had to with USB serial connect to VESC and set UAT+PPM and set to 9600.
-With those settings i get the app to connect, however have never been able to get the VESC tool to connect on my computer over bluetooth.

help :frowning:

(it was previously working with my Flipsky Bluetooth module and my VESC software on my Mac)… I just switched to a DSD HM-10 bluetooth module so i could use the xmatic app)


#447

After my ride and I try to save it it just says “Nothing to save. Get moving!” without saving anything. I had drove 7km in the app. Any way to fix it?


#448

Now it works. Weird