VESC - Hard Brake error

Hello everyone. I have been lurking here for a while but cant seems to find anything fully related to my problem.

Setup:

  • Space Cell
  • 2 R-spec Motors
  • 2 VESC (Updated to 2.15)

I have tweaked all the settings to the VESC per data from this forum. Currently running in CANBUS. PPM mode, current no reverse with brake

Problem:
When I go from full throttle to full hard brake, the motors will cut out and only the (slave) VESC will have a blinking red light. If I wait a few seconds for everything to settle, I can throttle again with no issue. Slow braking does not cause an issue.

What can I do to stop this?

what regen settings do you have>?

for battery & also motors?

I am following this link

For each VESC:
Motor Max: 80A
Motor min (regen): -60A
Batt Max: 15A
Batt Min (regen): -12A

try lowering the settings

Motor Max: 60A (or 40A)
Motor Min (regen): -20

eh. not working. now it seems to cause so intermittant issues with throttling back up. starts cogging (i think is the term) when throttling back up.

disabled CANBUS and I dont have the problem with single motor/vesc settings. guessing i am tripping some current limit…

Did you run the motor detection after updating firmware?

old thread i know…

im having the same issue, did you ever find a solution?

Post Screenshots of your general motor and advance motor settings.

I am having this issue with dual carvon’s/ space cell 4… Settings are as follows:

motor max: 30a
Motor min: -30
bat max: 20a
batt min: -8a
abs max: 65a

I have one board with these settings and 97mm wheels that works fine, this board has 90mm wheels. Anyone think the wheel size could make a difference? Anyone have any suggestions?

Raise your absolute max current to 120-130A

These are settings for a dual vesc…

Ok, raise your absolute current max on each vesc to 120-130A.

If you have this value to low the vesc will shutdown on a current spike and risk street your face

Oh, ok, I thought all the numbers where supposed to be divided in half?

Not the absolute max, it’s a safety mechanism for the vesc and it’s sensitive to current spikes (will shutdown the vesc once it hits that value)

But if you are having a shutdown issue apon braking, is your max input voltage set at 57V?

57v yep…

I wonder if the smaller wheels generate more amps? The 97mm board has the same settings and does not have the hard brake error…

Are you using FOC or BLDC?

I thought I already mentioned that they should be higher :stuck_out_tongue: Did you check for faults like I mentioned?

I am using FOC… Does anyone really use BLDC??? Can’t really check for faults because the vesc’s only cut out for a second, they are fine by the time I get home…

I’d say most people use BLDC, myself included. I’ll never use FOC until the VESC 6 as I’m not comfortable risking a $170 speed controller and potentially my life since I live in a place with a lot of hills.

Why can’t you check for faults? When they cut out they might be generating a fault. Just go home, plug it in, check for faults in BLDC tool. Just make sure you don’t turn it off in the time between.