EggsTravaGanZa 4-Day Sale

VESC - FOC braking trouble

foc
vesc

#1

I’ve got my VESC 4.7 configured with latest firmware (2.8FOC) and I’m having trouble using FOC mode. It will start from as stop very well, but when I apply brakes the motor seems to lose contact with the VESC and the controller doesn’t respond for a moment. There’s a “tick” sound from them motor and then no resistance at all, even though I’m still applying brake from the controller (GT2B). On the bench, I see that the red light is flashing when this happens. I don’t seem to lose connection to the VESC from BLDC Tool, so I don’t think that VESC is rebooting.

Any thoughts on what is going wrong? I love the quiet operation but not enough to lose the brakes! Build thread here pics of BLDC Tool configuration below.



Upgrading the VESC firmware
#2

On the foc tab have you run the tests and applied the results? I see zeros.
Also on bldc, you have delay checked. Mine is integrate.

Honestly though, I’m still trying to figure out what everything means.


#3

Wouldn’t it be great if Mr. Vedder had somebody looking over his shoulder and taking notes ?
It seems a lot of people are in the dark about what a lot of settings in the BLDC tool actually mean.
It’s a pity we have this genius piece of hardware at our disposal but nobody fully understands it.
There’s a dedicated VESC forum but I think a decent Wiki would be great.
I’m certainly willing to contribute.


#4

I have the same problem with VESC in FOC doesn’t brake very well. It brakes for 0.5 second then theres the tick sound just like you said then it started to loose the brake completely. I thought it was a setting misconfigured, but not quite sure after all.


#5

@trbt555 I was suggesting the same thing in another thread a few days ago! I was thinking that a configuration guide that covered all aspects of BLDC Tool would be a good start, although there’s clearly a need for a hardware wiki as well that might help those interested in building their own VESC from scratch. I think that a configuration guide is needed most, now that there are so many people buying VESC and trying it out.


#6

@laurnts thanks, it’s good to know I’m not alone. @jacobbloy @chaka @sl33py do any off you have ideas about why our braking is failing in FOC mode?


#7

Thanks @psychotiller! I ran the tests and applied the values to the configuration, the zeros are just showing that I didn’t calculate them when I took this screenshot. I applied “Delay” mode based on a thread I found on ES, but neither Delay nor Integrate seem to have an effect on performance.


#8

Vedder has been very up front about the FOC implementation and it’s “in development” status. Too many people are jumping the gun and expecting it to work flawlessly with auto detection.

I still recommend and use BLDC settings. The silent running is nice but I prefer the note our motors produce on bldc.


#9

Thanks @chaka you’re right, FOC is experimental. I was wondering if there was some obvious mistake I had made in configuring it, that might lead to stability and using it as my full-time setting. I really dig the silence!

Has anyone started using it without any problems? Taken an actual ride with it?


#10

I think @okp on ES has.


#11

I’m using FOC now for several weeks in 5 boards without problems (3 dual, 2 single) and I know at least 5 other guys in Europe using it too.


#12

So, any significant differences compared to BLDC ?


#13

It’s basically the sound only and the fact, that the start from a standstill is smoother and even more comparable to a sensored setup. I also tested the VESC with sensored motors and found no reason anymore for going sensored.
This might be different with MTB’s though.

FOC is nice but not a must.


#14

I’m running foc. I really like it and it set up easily.
Doing delay in bldc.
Did the 3 adjustments/tests on foc tab.
If u want help, not that I know much, message me and I’ll screen shot what i have and send it to you

My motors are 100kv which Vedder said being so low would be a help


#15

Thanks @Hummie. Mine is 245KV, I wonder if that’s too high. I doubt it though. Will PM you, would love to see how you’ve got things configured. I suspect that there’s a config somewhere that isn’t correct.

@elkick with 5 different boards you’ve got a lot of experience with FOC! Is there anything besides the automatic detection that you change when you configure your VESCs to run FOC? Settings that help to correct any issues?

May I ask everyone how long their battery wires are? I read that beyond 20cm the automatic configurations fail and\or become inaccurate.


#16

This works for me.

I heard maybe using “boost” in “motor config” “advanced” would be useful with such low kv but I didn’t change anything


#17

I had some difficulties in the beginning with 2.4, but they were gone with 2.7 and 2.8. Troubleshooting was alway successful when I installed a new FW and started over from scratch leaving everything at the default values first.

  1. switched to FOC in the main window
  2. BLDC section: enable delay, motor detection, apply, write config (& adjusted value when using hub motors)
  3. FOC tab: top down detection, always klick apply on the right side, at the end: write config
  4. Adjusted startup boosted (in advanced tab), but this has no effect with FOC, but just in case I’d switch back to BLDC
  5. Reboot
  6. Application config, write config, reboot (!)

And yes, I experienced troubles when the battery wires were to long, like 40cm. They are all 20-25cm now.