EggsTravaGanZa 4-Day Sale

VESC FAQ | Connect The Nyko Kama wireless wii NunChuck

nunchuck
faq
vesc

#200

That’s what I ended up doing. Got a hobby king remote. Now I’m still waiting on my enertion remote to come in but who knows when that will ever happen.


#201

I’m using a wii nunchuck while I’m waiting for my other remote to ship. For some reason if it disconnects the motor goes full throttle I tried searching the forums but couldn’t find anything is it just a setting in bldc tool ?


#202

I’m planning on using an RC remote to begin with just to get up and running, after that I will probably purchase two arduino banks and a receiver/transmitter for each. I’ll then empty most of the components from a wii nunchuck and use that as the body of the remote.


#203

Has anyone found a fix to the Nyko Kama not activating the motors?

The receiver light turns on and nyko kama remote connects and receives signals as when i push a button on the remote the receiver light flashes on and off, but does not spin the motors.

Using BLDC I can spin either motor just not using the remote.


#204

thats exacltly what I decided to do today. I even have one 3.3 and one 5v pro minis left over. going to buy 2 BT modules.


#205

Anyone based in Sydney and willing to help with finishing my build thats been put on hold for a few months now! Just need to get the nyko kama connected… willing to pay for your services.


#206

Hi!
i have a problem, looks like when i push “c” button, i have something wrong and instead on holding speed, i have some sort of interference. when motor spins, and i press"c" button, motor makes horrible noise (like it tries to do couple commands in same time)

if i press"c" button from stand still, motor starts to spinning with some constant speed, and if i try to change it with trigger motor makes horrible noise (like it tries to do couple commands in same time) again

here is connection. I double checked wire colours. i have 7pin port, instead if 6 pin.
Where am i making a mistake?


#207

What VESC version is that? Which software version?

Here’s a pic of mine. I followed this guide and it worked perfectly fine.


#209

4.12
i use Extended BLDC-TOOL with Watt Control Mode

could i damage a receiver?
i soldered everything, tested it, everything worked fine,
than i hot-glued it,
got a problem,
melted glue
took picture


#210

How is it wired on the VESC side? Also, just be sure that there are no bridged joins on the receiver (including the rest of the circuitry). Other than that, your problem is most likely due to EMF interference from the VESC / motor, or wiring.


#211

the problem is, that in some point it worked fine. and im doing everything in the same way.

any ideas how to fix this?
there is no bridges on receiver,


#212

Hmm… Perhaps you changed a setting in BLDC tool? Maybe disabled Nunchuk control? Or possibly the remote or the receiver is damaged. If you’re confident that the receiver is good, and it’s connected to the vesc good, then I would start looking at your settings, or the remote.


#213

Ill start with the settings, thanks.
Receiver looks solid, no visual defects


#214

It could be the batteries in the remote Are they fresh? Swap them out for AAA’s that are at least 1.4v, just to make sure we aren’t missing anything here.


#215

Remote is brand new, batteries too (stock). Have it for 2 weeks, made only tests


#216

Well, i reinstalled firmware, applied settings, and problem stayed the same(

its 100% hardware problem.
its impossible that it shows “over_voltage” error when gt2b and nyko receiver are connected in the same time with no reason

problem ether in receiver or in vesc. but how to fond out where exactly? the good thing that gt2b works perfrctly


#217

In BLDC Tool, go to the “Terminal” tab, then type “faults” and hit enter. This will list all the faults… What shows up?

And just to clarify, you have tested the GT2B and the Kyko with the fresh firmware? What hardware and software versions are you running now?


#218

I just finished my prototype radio setup using NRF24L01 for wireless but connected to the VESC via an Arduino Pro Micro that is emulating the Nunchuck I2C slave communication protocol. So the VESC will think it’s taking to a Nunchuck so the Vesc Nunchuck app should work, but with a better radio that isn’t susceptible to EM interference (assuming that is the problem and not power brown out) Bench testing this week.

Although the nunchuck has a serious cut-out flaw, but the current VESC Nunchuck “app” is miles ahead of PPM app in terms of smooth power and breaking. I’ve use both ways with every BLDC setup imaginable and could not get PPM to come close to the Nunchuck which has Ramping Time constant control. I asked B Vedder why he didn’t include it for PPM and he said he just never got around to it because he uses the Nunchuck mostly.

I heard that the VESC 6.0 Firmware (compatible with VESC 4.xx) is coming out sometime soon and will include the ramping setting for PPM as well. Long overdue in my opinion.


#219

What you’re doing is very cool! Is there a possibility of you selling these?


#220

Well I have to make it work first. Probably not, but I’ll publishing everything. VESC 6.0 firmware will solve this problem IMO…and everyone using a standard remote will be able to use ramping.