Buy FOCBOX Unity

VESC BASED CONTROLLERS - Brakes locking at low speed for larger wheels in FOC - possible Unity Fix


#1

@Deodand
@Eboosted
@mmaner
@psychotiller

with the unity under active development, i thought we could persuade @Deodand to finally address the locking brakes issue for larger diameter wheels in FOC.

it’s kind of been started already:

using this thread isolate the topic.


VESC Brakes grabbing coming to stop
NEED A FEW TESTERS WITH FOCBOX UNITY BUILDS - Low-speed Braking Fix Needs Testing
#2

@thisguyhere, you ordered a unity, and have a board that exhibits this behavior? When you have your unit in hand mind spending a couple hours with me debugging/solving the issue? Basically get the board setup with the issue active, we will test a few config settings, if that doesn’t work then I’ll send you some modified FW to test with different fixes. Once I find a fix I’ll open an issue on Vedder’s git so it gets fixed there as well.

If anyone with a beta unit has the issue I could start testing sooner.

Detailed descriptions of the problem, and also if it occurs in FOC/BLDC, Sensored/unsensored, and what is wheel diameter motor kv and gearing would be helpful.


#3

you got it, yea i’ve got unitys on the way.

will test it out when they get here, for sure.


#4

I’d be happy to help. I’ve got multiple boards the have this issue.

It would be no problem to swap out the FocBox’s in my Bludgeon 6 shooter build. I’m running 15/60 gears on 10s4p.

My latest build has the issue as well, phat Matson deck on 107 flywheels with dual FocBox’s on 12s3p.

My gear drive build had the issue buy I’m testing arc 200s in it at the moment. It’s a caldera deck on 7in numies with 12s4p.


#5

Yup, all my builds have this and I have learned to live with it. I just don’t understand how it is like this going forward but “slowing down” and stopping while in reverse doesn’t produce it. If that makes sense.

I really hope this goes away with the Unity.


#6

Could this be a issue with 12s battery setups that we saw on the flipsky esc as well maybe for some reason these are not able to handle a 12s battery


#7

I have a engineering test unit in a Lacroix deck, dual 6374

I think my setting are:
motor:
60A
-50A

batt:
60A
-20A

I have not felt this behavior


#8

What size wheels?


#9

Hmmm not sure about the wheel size, 6”? @Arch can you answer that

7"


#10

I’ll be setting up this build 10s. 220kv. 107s I’ll let you know


#11

Can we potentially change the title to VESC BASED CONTROLLERS - Brakes locking at low speed for larger wheels in FOC

Edit: Thanks!


#12

One thing that I’ll be implementing is scaling the plethora of erpm based settings based on motor flux-linkage during config. Essentially the flux linkage determines the amount of volts for a given ERPM, the amount of volts determines the signal quality that the unity has, and so for instance when to switch over from hall sensors to sensorless should just scale with the motor flux linkage and not require an additional config setting to work properly.


#13

Nope, it happens on 2 of my 10s builds.


#14

Links to those older threads if anyone wants to catch up


#15

I was able to solve this locking issue with my 105mm wheels by reducing the deadband from 15% to 2%. I’ve the mini remote. Give a shoot.


#16

I’ve always had this issue to some degree regardless of gearing/wheel size on my FOC sensored 10S setup. I’ve learned to live with it, but it would be great to not have to deal with it.

I’m not hip to how this stuff works, but talk of scaling something based on the back emf/erpm or whatever sounds sexy… This issue is one of those SUDDEN type things, and if it were even to just ramp slowly into the locking brakes that would be so much nicer.


#17

This is new, I’ll give it a try


#18

Are you talking about the full short braking when you reach a certain eRPM threshold? I thought there was a setting for this in 2.xx firmware which seems to be missing in 3.xx; or at least i can’t find it.


#19

Yeah I found “max erpm at full brake” is missing in 3.x firmware.

For me in BLDC mode lowering the number made the slow to stop much smoother.


#20

Gonna try that, too.

I got used to the locking brakes but would love to get rid of it. My bigger problem is when riding really steep downhill with my MTB with full braking, often the wheels block 100% and I start slipping or fall. This is really annoying. I have Vesc6 FW 3.38 with 149kv 6374’s running in FOC (12s) with 1:5 gearing on 8" wheels.