Certified FOCBOX Suppliers | Get Focbox Unity

VESC and GT2B problems


#1

Hello,

I have one big problem - VESC brakes motor when GT-2B transmiter is off.
How to make VESC not do anything when I turn off transmiter?
In BLDC tool I have 0A current in field about Timeout (when no control signal is received) and 10000ms delay.
I`m getting kind of glitches and today I hit a groud badly with my eMTB board.
I will check hardware, but it is possible to make VESC not do brakes when transmiter is off?

Thank you


#2

Theres somewhere setting to set the baud / gauss at 1500 upon signal lost from transmitter.


#3

In the main app tab: "Brake current to use…” can be set to make the motor brake with a certain current when a timeout occurs instead of just releasing it.

This needs to be set to 0,00.


#4

Yes, this is already 0,00 but I get really hard wheel lockup when I shut down transmiter. I checked this today 2-3 times. That lockup goes away after 20 seconds or so and then wheel with motor spins easy.


#5

Did you try to adjust the settings on the transmitter itself? There are some things that can be easily dis adjusted during usage.

It might send a brake signal to the VESC.


#6

Fail-safe?
Maybe.
I will test this with simple servo.
And also why I get dropouts and I get to ground…

Thank you.


#7

Yeah, check the receivers fail-safe thingie, that helped me


#8

Yes, got solved everything.
Firstly - receiver antena ground wire was broken from PCB. Soldered back.
Secondly - receiver fail-safe was kicking full brakes with no signal. Removed that with this tutorial - http://ibuyrc.com/manual/79P-FSGT2B-2CH-Car.pdf

Take care with your fail-safe because you will end up flat on ground…


#9

Hey again. Can i get in touch with you, about vecs?


#10

Yes, just write a PM.