Certified FOCBOX Suppliers | Focbox Unity 4 Day Sale

Simple 3D-printed NRF remote - Arduino controlled

electronics
remote
3d

#1411

Interchange the N and S poles of the magnet


#1412

Yeah, I thought that would be the easiest way… Done that…

But another serious issue. I built this remote like many months ago, and didn’t get freezes of the arduino whatsoever.
Today I flashed the code from the developement branch and it worked first flawelessly, arduino boots up properly and it worked out of the box. Then I wen to the settings changed the ranges and exited the Settings, still no problems. Turned it of, and on again to get into the settings, then wanted to generate an adress, and then it froze up.

Now the remote freezes up at the firefly logo or after a while on the info screen, or sometimes after pushing the throttle.

I tried to reflash the arduino with the firmware, it flashes but the problem remains with the random freezes of the Arduino. I also resoldered all pins on the arduino and the display and the NRF24 module.

I didn’t set up the receiver so maybe the unavailable receiver is messing up the Arduino after a while?!

Is it a common problem? I tried to search the thread for “freeze” but didn’t get any usable result.

And is there a way to reset/erase the EEPROM? Maybe it’s due to the settings in the EEPROM?!

Thanks in advance.
Ron


#1413

If you haven’t connected a nrf module it could crash - I haven’t tested it. I cant think of anything else. You can try to erase the settings by adding the function setDefaultEEPROMSettings() in the setup. However it should not be the issue :slight_smile:


#1414

To use the VESC 6 library do I have to have a VESC 6? I have a 4.xx. This is my current state of telemetry: New package: ‘0-543-0’
New package: ‘0-543-0’
New package: ‘0-557-0’
New package: ‘0-568-0’
New package: ‘0-550-0’
New package: ‘0-547-0’
New package: ‘0-557-0’
New package: ‘0-561-0’
New package: ‘0-543-0’
New package: ‘0-557-0’
New package: ‘0-561-0’
From the receiver. No data shows on the remote.


#1415

Thanks for the fast reply… I have connected all parts but still it is crashing… witth the initial version of the firmware I didn’t have such problems but after upgrading to current version even tho I downgraded to the initial firmware version I have this issue now of randomly freezing Arduino.


#1416

Off to buy some capacitors for the receiver. What voltage should they be?

“A good mix would be a 220uF, a 10uF and a 100nF capacitor in parallel.” 16V good enough?

And is it still needed when I add the 220uF to the arduino and add a 22pF to the reset - ground. (this is from the video of @SeeTheBridges)

Bit confused with because of the build video and the guide.


#1417

I am using this library for my VESC 4:

No battery, and the distance and speed:
com-optimize-3


#1418

Here are what I am using for the power filter capacitors. Voltages don’t really matter as long as they are more than 6v.

https://www.mouser.com/ProductDetail/594-K104K15X7RF53H5

https://www.mouser.com/ProductDetail/140-RGA100M1VBK0511G

https://www.mouser.com/ProductDetail/140-RGA221M1EBK0811G

In case you need a power switch:
https://www.mouser.com/ProductDetail/612-EG1201

I suggest you order some spares in case you break a lead off or something. I ordered two of each especially since how cheap they are.


#1419

The VESC6 library is backwards compatible.

@mptrs I can’t confirm whether you still need the reset cap if you’re using Geeks schematic for the power filter. My remotes don’t have them, so I include the reset-GND caps. You’ll just have to tell us if it works without!


#1420

I am not using the GND to reset cap and I haven’t had a problem yet, however that has been only 15 miles.


#1421

If anyone is interested, check out my thingiverse thing to see my nrf24_Remote mod with PCB. It’s got a longer handle. I am in testing phase and have verified solid radio connection and OLED and communication with VESC and so on. Hope you guys are making awesome remotes too! This project is exciting :slight_smile:


#1422

@SeeTheBridges you did your build after or before the guide? I think you have the 220uF to fix the power issue. And the 22pF is for fixing the arduino not getting stuck in setup I guess.

I’m not that into all the capacitor and resistor stuff hehe. But you never had any with power drops?


#1423

Thx for the help, will order from Ali :slight_smile:


#1424

Which guide? I built my first remote prior to Solidgeek’s written guide, but for my video series, I think all but the first part came out after the written guide from Solidgeek. I’ve also since that first remote switched to 100uF caps with no power issues.


#1425

I’m also having this issue with the crazy values… I have the latest firmware from the dev branch flashed…


#1426

Got my working and using mph now. After I cleared the Arduono IDE of all VESC libraries, restarted nd reinstalled the libraries, and reflagged the receiver and remote.


#1427

Was there any specific way you reinstalled the VescUartControl library or a specific way you reconnected the receiver and remote?


#1428

When you download the library, it should be a zip. Go to sketch then include library then add zip library or something. Then connect one of the arduinos and hit upload. Maybe unplug them after, and then make sure they both are connected to each other. The wireless icon should be solid, not flashing.


#1429

Does anyone know where I would point the D-, D+, ID pins on the my external micro USB jack so that it can double as a charger AND upload code to the Nano?
Does Rx = D- and Tx = D+ ?


#1430

Unfprtunately you need to to go through the arduino USB port to do so. Unless you added another external USB to serial converter in there. But why do that when there’s already a CH40g on the board haha

Sofu used a 4 pin micro USB breakout on her remote, I use the 5 pin breakouts on mine. Then you just have to match the pin outs.

On your picture there, from left to write the pins are 1-5. The data pins just need to match pins 2 and 3 on a microUSB breakout. On my remotes though, I have to use another cable feeding pin 5 too for some reason. Sofu only needs 2 and 3.