Certified FOCBOX Suppliers | Get Focbox Unity

Freefly Robotics new universal motor controller, ARC200. Thoughts?


#121

just reflashed the firmware, that seems to have cured it for now, but we have to start all over on settings.

it’s possible a phase lead short corrupted the firmware, we may have found a possible cause there.

also we’re finding these control modes often don’t make sense for esk8. For example, there doesn’t seem to be an exact equivalent for “forward no reverse with brake” as torque forward or whatever it’s called provides no braking when rolling backwards.

also the UI. It’s way to advanced. All of this needs to be hidden behind an Advanced Mode and the default needs to be something dead simple that allows you to: run detection -> adjust battery settings like max current and voltage cut offs based on cell count and Ah ratings -> play with motor amps -> tune remote -> save.

We’re not noobs and this interface has us throwing wrenches. But if you’re targeting high end DIY, it’s critical to have an easy way to get it working and then offer everything else once the builder is ready.


#122

That’s an interesting exception, I’ll have to look into that. Not sure why that’s happening! Does that come up right when you move the RPM set point slider? Looks like the number is correlated to that set point.

What is your max motor amps? If you have it set to 200, try a bit lower. Many motors have some stability issues at 200A and around 175A works much better. Also check out the FAQ “When I have a high max torque command (usually you run into this at 150A or greater commands) sometimes it just pops when given high throttle instead of giving torque” for more methods of fixing this: https://freeflysystems.atlassian.net/wiki/spaces/FRP/pages/278822913/Motor+Drive+FAQ+s+and+Common+Problems

In the future, save your config before updating firmware then you can just re-load the .UMDS2 config file so you don’t have to re-do setup.

In torque forward only, you should be able to brake, but you’d do it with the throttle not the brake. When rolling backwards, throttle still makes you accelerate forward which is now coming to a stop.

Thanks for the GUI feedback. This is our internal engineering GUI that sort of morphed into a public product. We certainly hope to greatly simplify things in the future.


#123
  1. Regen is set to 10.

yeah, we found that pretty early on. Crisis management and all that lol.

That is not really acceptable behavior for an ESC in this particular community. There needs to be a brake in which you pull back on the throttle to stop, and push forward to go. Directionally re-orienting is not so safe for a person, though i’m sure for a camera its fine and probably even desirable. Perhaps a new or different mode is in order.

That makes total sense. Obviously this is an earlier release, and i’m very glad to hear that you’re working on a way to dumb it down for us a little.


#124

Smart move guys, I see that the feedback your getting here is priceless.

We won’t have issues with your esc coz these guys will know how they work and they pass on knowledge.


#125

At the moment we’ve got the running strong and hard and they’re performing very well in general. To quote jake: “they’re stupid over complicated but they feel great.”

You have a niche here. this is clearly a racing ESC.


#126

Ok… to clarify, are you still having fault issues where it cuts out on accel and/or brake, or is that what seemed to be fixed by a firmware update? You should be good on just about any motor you’d typically pair to this drive up to around 150A accel or regen current but if you still end up with faults you’ll want to try the things in the FAQ entry I referenced.


#127

at the moment no, we’re not having any issues, we managed to get around whatever that error was during detection by reloading the firmware and saved settings.

The only complaints we have at the moment are with the UI, and with the lack of a “forward no reverse with brake” mode that works the way the rest of the ESCs in our community do.

Other than that, at the moment, we’re pretty happy with them.


#128

oh forgot to mention, Jake posted all the specs on the current test rig we’re using.

on the back… those are some seriously slick Slick Revolutions lol

I’m putting a parts list together for a more polished build using these for upcoming race events. If you have any giant stickers you’d like us to plaster all over it let us know. We will be repping these pretty hard at events if they don’t explode.


#129

I was out riding on the trail and got about twenty miles out before I stopped to do a volt check, when I tried going again, one of the motor controllers flat out stopped working. It stuttered and locked up, I tried to unplug it’s power lead to run single drive and it locked the other one up. I ended up having to plug it back in and unplug the phase leads going to the locked up controller to get the other one to spin up again and limp me home. I have yet to reflash the settings, but this seems like a DEAD Arc 200.


#130

I do not know what is causing this error to pop up during “Auto Measure R” detection. What ever it is totally locking up the esc. I tried reflashing the firmware, it did nothing.


#131

Sounds like something is blown in driver stage, either gate driver or mosfet, can be mosfet which shorts motor phases which prevents turning (brake effect)

I still haven’t yet touched mine working at the moment on several projects didn’t had time to play around with it :slight_smile:


#132

If you have a motor connected to the bad ESC, is that motor locked or cogging unexpectedly even if there is no power attached to the drive?

Also can you describe the wiring configuration for control? Is this PWM control? If so, are you using one primary and one secondary cable?


#133

“If you have a motor connected to the bad ESC, is that motor locked or cogging unexpectedly even if there is no power attached to the drive?”
No, there is not any cogging when you disconnect power from the esc. It only locks up when I power on the esc.
I am running split PPM using the wires included with the esc’s. One primary and one secondary connected to the esc’s.


#134

I think the easiest resolution is going to be to send you a new drive and have you send that one back. I’ll take a look at the drive and see if I can figure out the failure mode so hopefully we can avoid whatever went wrong in the future! Contact Freefly’s customer support (https://freeflysystems.com/contact) and direct the message to Bryan’s attention and he’ll take care of it.


#135

So… an interesting discovery was made. @christensent there maybe a chance this thing still works. After I had pulled on everything, ran detection, and pulled on everything again to see if there was a mechanical issue, I couldn’t find anything. Apparently I heatshrink my connections so well I didn’t notice a freaking busted solder weld. My appolgies for this giant headache of a blonde moment.


#136

It’s back up and running. For now.


#137

That’s great to hear. Send them over to rich-art or something :wink: