FOCBOX UNITY $299 | R-SPEC DRIVE KIT $588

Firefly Nano remote


#162

@DroidSector looking at the specs I see you are using a different hall-effect sensor than the original Firefly. Just to be sure, I can use the Honeywell that was specified with the original Firefly as well right? (I have an extra laying around hehe)


#163

I guess it should work:


#164

Thanks! Missed the voltage difference. A step-up isn’t that big, so I’ll keep that as an option.


#165

NO STEP UP! U have to use the 3.3V input on the feather/TTGO both are not 5V tolerant!


#166

If I added a step-up I should add a step-down as well I guess than. That sounds like too much work, I’ll get a 3.3V one if this one doesn’t work.

Thanks for the heads up!


#167

definitly…

but i many people told that the 5v honeywell sensor is working good on the 3.3v. the Honeywell SS49E is the 3.3V version of this.


#168

this line that you mentioned @DroidSector:

position = constrain(map(hallValue, settings.centerHallValue + hallNoiseMargin, settings.maxHallValue, 127 , 255), 127, 255);

it really gave a much better feedback and control on the throttle of the board. instead of only getting response half way through the throttle , now i have the full range of throttle motion in the thumbwheel.
I applied the same relation to the braking, that is another code line beneath. And its working really good.

Just that the screen is not refreshing in 25ms or something, it now updates info more slowly but honestly… i dont have any issue at all with that since im not looking at the remote all the time.

Thanks again @DroidSector, now with it all finished it really is an awesome transmitter!.

I checked on the code that there is cruise control code commented out. You think i could enable it or it needs further development ?


#169

This code is not ready yet, I’ve tried vesc built-in cruise control but it works with one motor only for some reason.

I’ve also tried to set the UART speed to 115200 and it worked good - much better data refresh rate, but I need to fix some problems. Will upload the code in a few days.


#170

Thats perfect because i only have one motor! :smiley:

Cant wait for that code update! :slight_smile:


#171

Hii @DroidSector ! I have read this whole topic and I really like your remote! Will probably use it for my next longboard.

I have a few questions however:

  • I want to use the TTGO board, do you already have a 3D design for it?
  • Does your code (on github) work with the TTGO board?

Thanks!

Edit: Another one:

  • What did you do with that antenna on the LoRa32?

#172

Not yet, still looking for a suitable board, should get latest Heltec board on Monday. The TTGO v2 does not fit without major enclosure redesign and small antenna connector does not work.

The good news is that the code is already compatible with both Feather and TTGO/Heltec boards. Menu, calibration and pairing should be ready next week.


#173

Nice that the code works! Not so nice the small antenna connector doesn’t, could other versions of this board maybe have a working small connector? Like the v2.1 for example? Looking forward to the results of the Helltec board!


#174

Unfortunately the heltec board is the worst one…


#175

What about these? 433 Mhz version.


#176

Sorry, I was talking about v2.1, but v2 has USB connector on the side and no battery probe. I also don’t really like that they changing the physical design every few months.

This is a good board for receiver.

@StefanMe I don’t see Heltec board in this video. Anyway, I hope version 2 will work better.


#177

Guess I will use that 433 Mhz then. That one is also legal hete.


#178

@DroidSector I’m running into this issue after installing the vibration motor. Uploading the program worked fine, it powered on through the usb initially, LCD lit up with information and connected to the receiver just fine. But once I disconnected from usb and attached the battery, the transmitter continued to fail. It blinks once and dies. Before the motor, the transmitter functioned as expected. After the motor, the transmitter refuses to power on even when connected to usb without the battery. The parts I’m using, save for the battery, are identical to those listed in your google doc. The battery I’m using should also be sufficient http://a.co/d/8wMa0mr

The board is still able to be recognized and programmed, but it simply won’t power on by usb or battery. This is the second feather I’ve tested with the same result. Again, same components, so I wouldn’t expect any compatibility issues.

I’m wondering if you or anyone else has experienced this and would be able to help me troubleshoot. For now, I’ll revert back to the motor-less configuration and hope I can get it back to working order :crossed_fingers:

Edit: /sigh disconnected the motor and it still won’t power on.


#179

Battery polarity correct ? I found I had to reverse mine as the plug came incorrect.


#180

Yeah, I’d mentioned that in an earlier post :slight_smile: but it’s not the case here. I’d fixed that early on and it powers the receiver just fine and charges, etc. I don’t think it’s the battery since the transmitter won’t boot up while connected to USB either.

I’m wondering if I overloaded the 3V / GND (if that’s possible? I’m no expert in electronics, definitely painting by numbers here). There would be three components on a split to 3V and five components to GND. But again, just using the parts recommended so I’m at a loss as to why this happens.


#181

Feather has 500mA peak regulator, so it should be enough for the screen (20ma) and motor (60-90ma). I’m using exactly the same vibration motor module.

If the board is still able to be programmed, it should be alive. Try to uncomment DEBUG directive in globals.h and check the serial monitor output. Also, make sure that only one line is uncommented in platformio.ini:

[platformio]
env_default = Remote.Feather
; env_default = Receiver.Feather

If you accidentally uncomment both PlatformIO will use the last one, i.e. receiver.