Buy FOCBOX Unity

DIY 6S to 12S BMS with CAN - DieBieMS


#551

Hey Guys,

I need you help. @JTAG

Just attached the DieBieMS to my 2 x 12s5p == 12s10p.
The balance cables and PACK +/- are connected.

  • DieBieMS does power up. HW V0.7
  • DieBieMS-Tools can connect to the MS states FW 0.16
  • FW Upload does work.
  • But after reboot - it is still 0.16
  • Can NOT read / NOT write values with the DieBieMS-Tool
  • only Terminal commands.
  • Strange “State of charge” - 1.5% - at 12s with 48.97V it should be above 90%

What am I doing wrong?

Please find all data below.

------- BMS Info -------
Firmware: V0.16
Hardware: V0.3
Name : DieBieMS
UUID: 33 00 3E 00 10 57 34 56 36 30 33 20
------- End BMS Info -------

----- Cell voltages -----
Cell voltage 0 : 4.088V
Cell voltage 1 : 4.089V
Cell voltage 2 : 4.080V
Cell voltage 3 : 4.089V
Cell voltage 4 : 4.089V
Cell voltage 5 : 4.089V
Cell voltage 6 : 4.089V
Cell voltage 7 : 4.088V
Cell voltage 8 : 4.089V
Cell voltage 9 : 4.089V
Cell voltage10 : 4.089V
Cell voltage11 : 4.083V
Cell voltage high : 4.089V
Cell voltage low : 4.080V
Cell voltage average : 4.088V
Cell voltage mismatch : 0.009V
----- End Cell voltages -----

-----Battery Pack Status-----
Pack voltage : 48.97V
Pack current : 0.02A
State of charge : 1.4%
Remaining capacity : 0.57Ah
Operational state : External (USB or CAN)
Load voltage : 0.00V
Cell voltage high : 4.089V
Cell voltage low : 4.082V
Cell voltage average : 4.088V
Cell voltage mismatch : 0.008V
Discharge enabled : False
Charge enabled : False
—End Battery Pack Status—

— BMS Configuration —
NoOfCells : 12
batteryCapacity : 41.00Ah
cellHardUnderVoltage : 3.400V
cellHardOverVoltage : 4.250V
cellSoftUnderVoltage : 3.300V
cellSoftOverVoltage : 4.250V
cellBalanceStart : 4.100V
cellBalanceDiffThreshold : 0.010V
CAN ID : 10
— End BMS Configuration —


#552

OK @JTAG - read the whole thread again and found the part where you describe the bootloader_jump command.

Now it says v0.21 in the DieBieMS-Tool - but the LCD states v0.17 at boot.

Is this normal?


#553

Hi guys!

Sorry for the lack of response from me lately I have been very busy. But also busy on adding new features to the BMS and the interface. The most important thing I am working on is a self test feature to test the BMS after production and changing the hardware to add test pads for a test fixture.

I will soon take time to answer all unanswered questions soon!

And for the last question, I am sorry that might indeed be a bug :stuck_out_tongue: . I still have to automate incrementing the firmware version on every place in the firmware automatically.


#554

DieBieMS is now managing 12s10p of 20700B.

Wow - this is just the coolest BMS around!
Thanks @JTAG from Hamburg.


#555

@JTAG anything buddy?
:slight_smile:


#556

you can maybe still get one here


#557

Was actually referring to the “More amps shield” that he was (or is) developing,
Thanks though!!


#558

It’d be great if someone would do a large run to keep these in stock. I don’t need one right now, but in the future it’d be great to have to option to buy it outright instead of waiting on a GB. I could see this becoming the new standard if it we’re more available.


#559

I made extras with this run.

Sam


#560

@JTAG didn’t see it anywhere, but would this work with Hobbywing Max6 ESCs and off the shelf Turnigy cell packs? Do I need to have a Vedder based ESC?


#561

you dont need a vesc, but some of the functions will not work without it


#562

@JTAG

Thank you so much for this great work. I’ve been loosely following your progress from the beginning and I’m catching up now on what I’ve missed lately and it’s a lot.

I have 2x the V0.8, and reading back, I saw you mention the MoreAmpsShield last December (2017). I haven’t seen anything about this since then. Do you have any idea when I could expect more from this?

I’m debating what to do right now as 80a is just not enough for me (was trying to do 200a+, as I run 4wd). I read before the plan was to allow this to support 140a in theory as it is. Have you tested this yet? Is there a 140a fuse that will fit nicely?

Charging wise, limit is 15a, correct?

I’m a bit confused on the charge current. You said to detect charge, it needs to be 3v above pack voltage? So it won’t detect a charge if say my pack is at 49v and the charge current is 50.4v? Do I need to set it to 53.4 then?

I’m still confused about the canbus connection to the vesc, but hopefully I find something that clarifies this soon (still not done reading all of the topics and every message, soooo much to read, haha). Do you just need to connect CAN L BMS -> CAN L VESC and CAN H BMS to CAN H VESC?

The manual would be great. I might through something together in the mean time for others, because it’s not efficient for everyone single person to read all of these lengthy threads. Already been about 4 hours and I still have at least 2 more to go through.

Thanks again for this amazing piece of work. Would love to use the full power potential of my setup though (200a+, could even set each vesc to 80a for 360a total in theory). I think it’s worth limiting my power output for the time being and using this instead of not using a bms, since I’m now using a 25ah lipo pack. But would love to get this running at higher amps.


#563

In general, the ESC should have no effect on the bms. They are separate, compartmentalized systems. This bms has a canbus port, which the vesc also has, and it seems there’s some firmware stuff being implemented so the VESC and BMS can be blended together nicely. But this is the icing on the cake.

Personally, I would recommend a VESC, especially a VESC 6. I’ve tried pretty most vesc’s out there and the only ones standing still are the official VESC 6 (damn you Frank for charging so much!!! I know how cheap your BOM is now!) and the Axle and Chaka Vesc 4.12’s. It pays in the long term to use quality parts (remember, electric skateboarding can be deadly, especially if you experience electrical failures at the wrong time).


#564

Charge voltage:
should 0,7v above pack voltage to be able to fully charge (due to protection diode

the CAN connection:
VESC1 | VESC2 | BMS
canH | canH | canH
canL | canL | canL
– | 5v | 5v CAN
– | 5v | Enable Can (<-- connect to 5v for push2Start)
GND | GND | GND

5v_CAN is mandatory to power the primary can circuit on the dbMS
Enable_Can is optional connected to 5v_VESC for push2Start

pinout of the dbms


#565

Do you guys also realized that the two chips between the positiv ports do get HOT?
And that every other BMS got heat sinks but DieBieMS does not.

Did someone worked on this?


#566

@rene Do you or anyone one else have any adivce on crimpting the J12 connector? Maybe the wire I’m using is too large or something, but I’m having a hard time getting those little legs to clip. It looks pretty clen and narrow, but when I pull it out, the legs look bent inward and I have to use tweezers to pull them back out. But everytime I try to insert it, the pins get pushed in and stay, they don’t spring back out and get connected, even though I get the entire pin in.

Any advice is much appreciated as it’s driving me crazy to where I want to just de solder the port and solder directly. to the pcb haha. But I’m trying to restrain myself.

Does anyone know of the proper name for this connector? I wouldn’t mind even picking up a pre-crypted cable with the port on it. All I can find on the schematics and BOM is J12.


#567

Its a WR-MPC3 connector that should be used with 20-24AWG wire. At least that is the conclusion I came to. :sweat_smile:


#568

So this wiring diagram unfortunately doesn’t help with the latest gen of switches. They have the following listed names: C, NO, NC, LED, and A.

Doesn’t anyone know the correct wiring?

I would love to get this bms working. I’m just finding it hard as information gets old and then theirs no documentation for most of what I’m have to do as the end user to get this running.


#569

What would have been amazing for future groups buys would be if cables were pre-crimped and wires pre soldered to the switch. I would pay an extra $30 to not have to guess and break stuff trying to figure out what is what.

So far, I likley blew the first one because I got frustrated with this stupid balance plug.

The second one is like the first, in that I plug it into the computer and windows chimes and it shows under devices. But it doesn’t find it when I used the DieBieMS tool. Both are v0.8. I get no lights on the bms, either. I connected my battery to it and tried to use the switch, but nothing works. It’s been over 15 hours now I’ve spent trying to get this bms working and I’m ready to just throw it in the trash and move on.

Update: So the second one I was able to get the firmware updated, and it now powers on when I plug in the usb. But it shows 0 volt for the battery pack. It this because I don’t have the battery balance wires plugged in? It shows the bms temp correct (I activated rt data).


#570

The correct wiring for the switch is:
C and NO for the switch. That is the red and black wire.
LED and A is for the LED. The green and the blue wire.
The yellow one is not used. Same with the NC contact of the switch.