Certified FOCBOX Suppliers | Focbox Unity FREE SHIPPING

Configuration and telemetry for VESC [iOS, Android]

tools
detection
vesc
configuration
metr

#1129

sent.

seeing this in the logs:

“app: RT TIMED OUT 1”


#1130

Found a bug where perimetr does not read you are running sensored. At least it does not show it when you are.

Still iphone 7 on 11.4.


#1131

Can you explain in more details? What doesn’t it show exactly?


#1132

just an update. All seems well now. Seems that I have to have the board on for a bit before I’m able to read the motor configuration. Not sure if it’s always been that way or it’s something new. Either way, thanks for the awesome and quick responses over email @rpasichnyk!


#1133

Thanks a lot, will try it


#1134

I run sensored motors. When I read them in perimetr they show as sensorless even though I have set this in the vesc tool to sensored.


#1135

Still problem with custom voltage, log sent with screenshot from gmail account. I also suspect that app is somehow limiting my current to 20A as I don’t suspect drawing max 20 going 53kmh max with 33 average.


#1136

@rpasichnyk So I just hooked up my meter module to my new build and my metr app or perimeter app can’t detect it. Phone is Android 8.0.0, but Acmaniac’s app can see the module however it can’t interact with it fully.
My baud rate is 9600 I also tried 115200 or something like that, that was suggested above. Did not work.
The red light keeps flashing all the time. Is there anything I need to do to get this running?


#1137

Please send log file (Settings - Show Log) to support@metr.at


#1138

How do I connect the meter with BLDC Tolls on MacOS by bluetooth?

I see only this and can not connect.

I found. It is necessary in the meter to activate the TCP bridge and the TCP server input in BLDC tools.

But now he writes:
The connected VESC has too old firmware. Since the connected VESC has firmware with bootloader support, it can be updated from the Firmware page. Until then, limited communication mode will be used where only the firmware can be changed.

Although I put the latest version of VESC - FW 3.34 I used MacOS and BLDC Tools 0.95 - not work
But when I used BLDC Tools 0.87 - all work


#1139

Hello… I just wonder what could be the issue with modes in the metr app when having the 3.102 Ackmaniac Firmware on my VESC. Is it supposed to work or is it not supported to switch modes with metr with this firmware ? Thanks


#1140

@Ingvarjedi Bluetooth connection to your Mac is only possible with the Metr Pro module. For the standard module you can only use TCP bridge for wireless connection.
For me that sounds like your firmware update didn’t worked and you are still on the old firmware. What does the BLDC Tool 0.87 you can connect to says about which firmware is installed?

@RyuX Normally Ackmaniac’s firmware 3.102 should be supported. I don’t have access to a VESC right now, so maybe someone else using that firmware can confirm if changing modes is working for them.


#1141

Hey @hexakopter

What is also strange is that my bluetooth module (metr-444) will not show up in the ESC Monitor from Ackmaniac (but it did some months ago when i last tried).
However the metr bluetooth module will connect with the metr app and I can read the current VESC values properly - but when trying to Apply modes it will say writing to Vesc #1 for around 5-10 seconds and then stop without any error message. However when reading the current values I see that nothing has been applied :frowning:

Edit: I am using a Samsung Galaxy S7 Edge with Android Oreo 8.0 - however i experience the same issues with a S5 and Android Kitkat.
Also another strange thing is that the metr.at App will work with the bluetooth module - however if I try to scan for the bluetooth module again it will not find it. So basically I can not find the module on any app (Ackmaniac VESC Monitor, metr.at, perimetr) it is only working on metr.at App because it was already found. Is there something on the module itself that makes it “invisible” ?


#1142

I have a very strange issue that I just noticed. For some reason my uploaded data is different than the data reported in the app and not just a little different.

Take a look, this is the first time I’ve noticed this. https://metr.at/r/D4t3H

Very different than the ride it shows in the metr app


#1143

@RyuX your module is not showing up, because BLE discovery is not working on Android 8 with old modules. The important to understand it is only discovery that does not work. If the module is already discovered and Android knows it’s MAC address, you can connect to it and communicate with it. When different apps perform BLE discovery operation, they can not find metr-444 old module. Regarding modes, try to apply again and right after that Settings Show Logs and send to support@metr.at

@strattos Thanks for your report. I can explain how that happened. Both the app and the web app ignore some data, because plotting all the values would take too much time. The reason you noticed such dramatic difference is because you have extreme point in your record that is 52kmh surrounded by 25kmh and 15kmh (you most likely just pressed the throttle when holding the board in your hand or something). This point was ignored in the app, but not the web app. I will try to fix it :slight_smile:


#1144

Thanks for the reply… I sent you the log to your email. Please let me know if you got it.
Cheers


#1145

@RyuX This happened because Ackmaniac changed PACKET_RX_TIMEOUT in 3.102 from 1000 to 50 milliseconds (no idea why btw). When you try apply the mode, the MC_WRITE_CONF packet is quite big and it needs to be split to multiple pieces. It gets timed out before fully transferred.

Metr Pro still works though, because it assembles the packet in memory before sending to VESC. But not the old modules.


#1146

Hello… Any hint how I can fix it ? Don’t want to buy a new module all of a sudden :frowning:


#1147

Yes, you have plenty of options even if you don’t want to buy Metr Pro:

  1. modify PACKET_RX_TIMEOUT in 3.102 and recompile
  2. downgrade to 3.101 or 3.100
  3. use official firmware 3.40

#1148

The stats for my board are stuffed because of a random corrupt record… I deleted the record from my rides but the all time stats are still incorrect. Is it possible to have the all time stats recompiled from the records that I have checked?