Certified FOCBOX Suppliers | Focbox Unity FREE SHIPPING

Configuration and telemetry for VESC [iOS, Android]

tools
detection
vesc
configuration
metr

#1009

If the record was already stopped, there is a very little chance it was lost. I think it should be there, you can also navigate with file browser and find it manually (each record has 2 files *.r and *.s extensions)

Today I borrowed Android 8 and tested location fix which seems to work fine in the latest version (2.2.64)

Thank you everyone for finding bugs, please remember it is always more helpful when you send along your log file :+1:


#1010

did you received my logfile via email?


#1011

@rpasichnyk now I can confirm that everything is back to normal after the latest update, both VESC’s detected, GPS perfectly in sync with the rest of the data

Thanks

Also I liked the new record upload popup, sometimes I wasn’t sure if the record was indeed being sent, some longer rides take a while to finish


#1012

Yes, thank you. I hope I found the issue and fixed it couple of days ago. But in case you get strange numbers again, let me know!


#1013

until now no update in the appstore


#1014

There was an update, can’t you see it on your device?


#1015

Hi I made it to fully work in 8.1, nothing special but that’s what I did,
Fresh clean downgrade to 7.1.1, set up all my apps metr included and was working perfect, but accidentally I install the 8.1 OTA :frowning:
Curious was the app still remember the module from the 7.1, I did not search again for the module it was there, and did connect without any problems and data is going up and down!! :slight_smile:
Now I have the goodness of 8.1 with metr in my one plus 5t!:sunglasses:


#1016

latest version. sorting of records still odd. i resorted several time before taking the screenshot.


#1017

This is expected behavior. You probably didn’t notice that records on top are marked as “Favorites”. I agree that might be hard to see, I should make it more obvious.

Favorite records will always appear on top. If you don’t want that, remove them from favorites.

remove


#1018

Did a 67 minute ride yesterday, no crashes or anything on newest Android app. Location and gps worked perfectly :smiley:


#1019

ohhhh shit … my bad! thanks for the heads up.


#1020

looks nice now.


#1021

I asked this on another app thread, do you know how easy this would be to add support for the Fitbit Ionic? Looks like it accepts javascript, css, and svg languages.


#1022

This happened just now. Had to reboot the app. It happend when I pushed the throttle with wheels in the air. I’m going to send log file via email.

Recorded on iOS, v.2.2.64. Look at how current is straight line even though data is there:


#1023

Thanks for the very detailed description! I could find in the log file exactly what went wrong

[I 21:50:30.402] Ask.version()
[I 21:50:30.957] VESC FW3.38 HW60
[I 21:50:30.957] Ask.version()
[I 21:50:31.996] Ask.version()
[I 21:50:32.547] VESC FW0.0 HW

for some reason the data got corrupted and firmware version was detected as 0.0, which in turn resulted in using old command codes (for 2.x) firmware and completely messed up Realtime Data. I will try to provide a fix soon!


#1024

Nice to se your fix @rpasichnyk … Looking forward to try


#1025

Hey so I got the module tonight and did the wire switching and modified the connector to fit the VESC6 one - I just want to double check before giving it power does this all look right to you?


#1026

Yes, looks good!


#1027

Thank you everyone and sorry for the latest couple updates that had issues. The reason for this is that huge amount of code has been merged into the master branch in the preparation for something really really cool. I wanted to make sure all the existing functionality remains intact which seems like the case after hot fixes. Most of the changes are done under the hood and not visible… for now :wink:


#1028

boooooom 10 char